Cannot create project

May 30, 2007 at 3:52 PM
Hello Martijn,

I installed the wizard and ran it. Using VSTS (VS2005) and BizTalk 2006 DE. When I check Finish to generate the stuff, I get this error:

System.Runtime.InteropServices.COMException (0x80040402): Cannot create project. The project folder 'c:\helper\myprojects\" already exists and contains other files and folders.
at EnvDTE.SolutionClass.AddFromTemplate...
at Microsoft.VisualStudio.TemplateWizard.Wizard.Execute...
at EnvDTE.SolutionClass.AddFromTemplate...
at MartinHoogendoorn.BizTalk.Wizards.PipeLineComponenbtWizard.BizTalkPipelineWizard.CreateProject ...


any help?

João Martins
May 30, 2007 at 5:21 PM
Hello again,

I was looking into it in the debbuger. The call that fails is the Solution.AddFromTemplate. I looked at the folder, and there's a myProjectName.gpState xml file there after the error, where GPS stands for GuidancePackageState (from its contents). This means that this file - which is apparenty causing the problem - is being created by some component in the Guidance Automation Toolkit/Guidance Automation Extensions (GAT/GAX) stuff, which I do have installed.

Thanks anyway,
João Pedro Martins
Jul 14, 2007 at 3:07 PM
I have the same issue. Do we have any workarounds for this problem ?
My setup has VS 2005 - Biztalk 2006 - GAT/GAX on Vista Ultimate.

Many thanks

Jul 14, 2007 at 4:40 PM
No luck on solving this. A workaround is using the pipeline component wizard in a box without gat/gax installed.
Aug 13, 2009 at 7:46 PM

I ran into the same issue, but I do not use gat/gax.  I received the exact same error message and had the exact same symptoms.  This post led me to look at anything that has to do with file/project creation.  I recently installed a source safe plugin and the plugin did not like the wizard; I would imagine that it is all wizards, since the third party tool is probably not smart enough to figure out what the IDE is trying to do, or there is some locking, etc. 

To turn off your souce control, go to Tools->Options.  Expand "Source Control"->Plug-in Selection and choose None from the list.

I dorked around with this for over an hour before realising the "bigger picture".

I was going to comment and post a question, but hopefully this will answer some.

Nov 24, 2011 at 10:44 AM

Hi all,

just uninstalled the GAX and it indeed is the problem. I have created several projects for my custom pipeline components and will just use these as templates.

regards Rob